生活在常宁,爱上常宁论坛! 广告服务

 找回密码
 免费注册

手机号码,快捷登录

7731查看|21回复

交换机路由器的最简单入门指令

[] [复制链接]
发表于 2011-7-5 14:43:47 | 显示全部楼层 |阅读模式
计算机命令:

PCA login: root                                   ;使用root用户
password: linux                                  ;口令是linux
# shutdown -h now                                 ;关机
# init 0                                          ;关机
# logout
# login
# ifconfig                                        ;显示IP地址
# ifconfig eth0 <ip address> netmask <netmask>         ;设置IP地址
# ifconfig eht0 <ip address> netmask <netmask> down    ; 删除IP地址
# route add 0.0.0.0 gw <ip>
# route del 0.0.0.0 gw <ip>
# route add default gw <ip>                         ;设置网关
# route del default gw <ip>                         ;删除网关
# route                                          ;显示网关
# ping <ip>
# telnet <ip>                             ;建立telnet之前先ping一下

^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

交换机基本状态:

switch:                                        ;ROM状态
rommon>
hostname>                                     ;用户模式
hostname#                                     ;特权模式
hostname(config)#                               ;全局配置模式
hostname(config-if)#                             ; 接口状态


交换机口令设置:
switch>enable                                  ;进入特权模式
switch#config terminal                           ;进入全局配置模式
switch(config)#hostname <hostname>               ;设置交换机的主机名
switch(config)#enable secret xxx                   ;设置特权加密口令为 xxx
switch(config)#enable password xxx                ;设置特权非密口令为 xxx
switch(config)#line c*****ole 0                    ;进入控制台口(Rs232)初始化
switch(config-line)#line vty 0 4                    ;进入虚拟终端virtual tty
switch(config-line)#login                         ;允许登录
switch(config-line)#password xx                   ;设置登录口令xx
switch#exit                                    ;返回命令



交换机VLAN设置:
switch#vlan database                             ;进入VLAN设置
switch(vlan)#vlan2                              ;建VLAN 2
switch(vlan)#no vlan2                           ;删vlan 2
switch(config)#int f0/1                             ;进入端口1
switch(config-if)#switchport access vlan2          ;当前端口1加入VLAN 2
switch(config-if)#switchport mode trunk             ;设置为干线

交换机设置IP地址:
switch(config)#interface vlan1                     ;进入vlan 1
switch(config-if)#ip address <IP> <mask>            ;添加远程登录IP
switch(config)#ip default-gateway <IP>              ;添加默认网关
switch#dir flash:                                   ;查看内存

交换机显示命令:
switch#write                                        ;写入保存
switch#show run                                     ;查看当前配置信息
switch#show vlan                                    ;看VLAN
switch#show interface                               ;显示所有端口信息
switch#show int f0/0                                ;显示端口0的信息
switch#reload                                     ;重新起动

^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
路由器显示命令:

router#show run                                     ;显示接口
router#show interface                               ;显示接口
router#show ip route                                ;显示路由
router#show cdp nei                                 ;看邻居


设置口令:
router>enable                                       ;进入特权模式
router#config terminal                              ;进入全局配置模式
router(config)#hostname <hostname>                  ;设置交换机的主机名
router(config)#enable secret xxx                    ;设置特权加密口令为 xxx
router(config)#enable password xxx                 ;设置特权非密口令为 xxx
router(config)#line c*****ole 0                      ;进控制台口(Rs232)初始化
router(config-line)#line vty 0 4                     ;进入虚拟终端virtual tty
router(config-line)#login                          ;允许登录
router(config-line)#password xx                    ;设置登录口令xx
router(config)# (Ctrl+z)                           ; 返回特权模式
router#exit                                     ;返回命令
配置IP地址:
router(config)#int s0/0                          ;进入串Serial接口
router(config-if)#no shutdown                    ;起动接口
router(config-if)#clock rate 64000                 ;设置时钟
router(config-if)#ip address 10.1.1.1 255.255.0.0     ;设置IP地址和子网掩码
router(config-if)#ip add 10.1.1.2 255.255.0.0 second;
router(config-if)#int f0/0.1                       ; 进入子接口
router(config-subif.1)#ip address <ip><netmask>     ;
router(config-subif.1)#encapsulation isl <n>         ;
router(config)#config-register 0x2142              ;跳过配置文件
router(config)#config-register 0x2102              ;正常使用配置文件
router#reload                                  ;重新引导

复制操作:
router#copy running-config startup-config           ;存配置
router#copy running-config tftp                   ;上载
router#copy startup-config tftp
router#copy tftp flash:                           ;特权模式下升级IOS
router#copy tftp startup-config            ;下载配置文件到nvram

ROM状态:
Ctrl+Break                                    ;进入ROM监控状态
rommon>confreg 0x2142                        ;跳过配置,26 36 45xx
rommon>confreg 0x2102                        ;使用配置,恢复工作状态
rommon>reset                            ;重新引导,等效于重开机
rommon>copy xmodem:<sname> flash:<dname>     ;从c*****ole升级IOS
rommon>ip_address=10.65.1.100                  ;设置路由器IP (默认端口)
rommon>ip_subnet_mask=255.255.0.0              ;设置路由器掩码
rommon>tftp_server=10.65.1.48                   ;指定TFTP服务器IP
rommon>tftp_file=c2600.T                       ;所要下载的文件
rommon>tftpdnld                               ;ROM监控状态下升级IOS
rommon>dir flash:                              ;查看闪存中的内容
rommon>boot                                  ;引导IOS

静态路由:
ip route <ip-address> <subnet-mask> <gateway>   例:
router(config)#ip route 10.1.0.0 255.255.0.0 10.2.1.1
router(config)#ip route 0.0.0.0 0.0.0.0 1.1.1.2     
动态路由:
router(config)#ip routing                         ;启动路由
router(config)#router rip                         ;启动RIP路由协议。
router(config-router)#network <netid>              ;配置范围,有的支持all。
router(config-router)#neighbor <ip-address>         ;点对点 帧中继用。

帧中继命令:
router(config)# frame-relay switching             ;使能帧中继交换
router(config-s0)# encapsulation frame-relay       ;使能帧中继
router(config-s0)# frame-relay intf-type DCE       ;DCE端(需要配虚电路)
router(config-s0)# frame-relay local-dlci 20        ;配置虚电路号

基本访问控制列表:
router(config)#access-list <number> permit|deny <source ip> <wild|any>
router(config)#interface <interface>               ;default: deny any
router(config-if)#ip access-group <number> in|out   ;default: out

例:
RB(config)#access-list 4 permit 10.8.1.1
RB(config)#access-list 4 deny 10.8.1.0 0.0.0.255
RB(config)#access-list 4 permit 10.8.0.0 0.0.255.255
RB(config)#access-list 4 deny 10.0.0.0 0.255.255.255
RB(config)#access-list 4 permit any              
RB(config)#int f0/0
RB(config-if)#ip access-group 4 in

扩展访问控制列表:
access-list <number> permit|deny icmp <SourceIP wild> <destinationIP
wild>[type]
access-list <number> permit|deny tcp <SourceIP wild> <destinationIP
wild>[port]
例1:
router(config)# access-list 101 deny icmp any 10.64.0.2 0.0.0.0 echo
router(config)# access-list 101 permit ip any any  
router(config)# int s0/0
router(config-if)#ip access-group 101 in
例2:
router(config)#access-list 102 deny tcp any 10.65.0.2 0.0.0.0 eq 80
router(config)#access-list 102 permit ip any any
router(config)#interface s0/1
router(config-if)#ip access-group 102 out

router(config)#no access-list 102
router(config-if)#no ip access-group 101 in

发表于 2011-7-7 03:55:42 | 显示全部楼层
我等你哟!  
发表于 2011-7-7 03:55:42 | 显示全部楼层
原来还有这么多内幕啊,长见识了,呵呵  
发表于 2011-7-7 03:55:42 | 显示全部楼层
晕死也不加点分  

评分

参与人数 1威望 +1 收起 理由
zhenlinchuan + 1 [www.sz.hren8.com朔州论坛]

查看全部评分

发表于 2011-7-7 04:57:14 | 显示全部楼层
风物长宜放眼量  
发表于 2011-7-7 05:21:45 | 显示全部楼层
严重支持!
发表于 2011-7-7 05:21:45 | 显示全部楼层
感謝樓主  
发表于 2011-7-7 05:21:45 | 显示全部楼层
希望大家都有好运  
发表于 2011-7-7 05:21:45 | 显示全部楼层
必须顶  
发表于 2011-7-7 05:22:35 | 显示全部楼层
哥最近喜欢上了顶贴,因为,如果帖子火了,那有哥的功劳。如果帖子被顶沉了....哥也会很有成就感...因为是哥搞沉的~~大家切记~不要迷恋哥~哥只是一个传说
您需要登录后才可以回帖 登录 | 免费注册

本版积分规则

b6广告位招商
快速回复 返回顶部 返回列表